Jump to content

Archived

This topic is now archived and is closed to further replies.

Nikerocks

garmin 405

Recommended Posts

You never check with them?

I bought mine from Perfect Watch @ Simlim, and for repair, I just sent in with receipt to:

NaviCom Technology Pte Ltd.

200 JALAN SULTAN #10-03, TEXTILE CENTRE

Just got my watch from East Gear.How do I claim warranty for it if anything goes wrong?WIth the receipt or need to register online?
Link to post
Share on other sites
You never check with them?

I bought mine from Perfect Watch @ Simlim, and for repair, I just sent in with receipt to:

NaviCom Technology Pte Ltd.

200 JALAN SULTAN #10-03, TEXTILE CENTRE

huh, have to send there?? Normally I would just go down to the shop for an exchange :LMAO:

Link to post
Share on other sites

I didn't know they will let you exchange there cuz the last time (few years back), they ask me to go to Textile Centre.

You never check with them?

I bought mine from Perfect Watch @ Simlim, and for repair, I just sent in with receipt to:

NaviCom Technology Pte Ltd.

200 JALAN SULTAN #10-03, TEXTILE CENTRE

huh, have to send there?? Normally I would just go down to the shop for an exchange :LMAO:

Link to post
Share on other sites
I didn't know they will let you exchange there cuz the last time (few years back), they ask me to go to Textile Centre.

they grumbled a little, asked me if I knew how to use or not (do I look like I don't know anything zzz) , but still exchange for me. haha....

Link to post
Share on other sites
You never check with them?

I bought mine from Perfect Watch @ Simlim, and for repair, I just sent in with receipt to:

NaviCom Technology Pte Ltd.

200 JALAN SULTAN #10-03, TEXTILE CENTRE

huh, have to send there?? Normally I would just go down to the shop for an exchange :LMAO:

hehe how many times have u exchange? *touch wood*

Link to post
Share on other sites
u mean hanging when wet?

when I run LSD, it always hang. No reading. No number. Cannot change or anything too. i thought it is gone. But after that, the reading comes back.

And my garmin takes like 10min to connect.

I am impress u are really fast... hmm, u updated the software? That happens to my previous watch the 205. Did you lock the bezel when u go on LSD?

Link to post
Share on other sites
I am impress u are really fast... hmm, u updated the software? That happens to my previous watch the 205. Did you lock the bezel when u go on LSD?

Sometimes lock, sometimes not. Most of the time I lock it in case the sweat comes out and it get stuck in the screen I don't want to see :D.

one more thing, these fews days when I first started the watch, suddenly the screen goes to some kind of error too :(. The reading jumps, 2.xxx pace, then no distance recorded. Sigh.... quite upset with it now...

Software updated to the lastest.

Link to post
Share on other sites
I am impress u are really fast... hmm, u updated the software? That happens to my previous watch the 205. Did you lock the bezel when u go on LSD?

Sometimes lock, sometimes not. Most of the time I lock it in case the sweat comes out and it get stuck in the screen I don't want to see :D.

one more thing, these fews days when I first started the watch, suddenly the screen goes to some kind of error too :(. The reading jumps, 2.xxx pace, then no distance recorded. Sigh.... quite upset with it now...

Software updated to the lastest.

Sorry to hear that. Hai, I think better to get it change and extend the warranty.

Link to post
Share on other sites

wow so many problems?? :Praying: i had brought my toy out for 3 runs so far.. 7 to 11km.. so far quite ok... only the gps.. took a while to connect.. and the worse thing is my bezel got chip off slightly...heart pain.. i remember i did not hit on anything or drop at all.. :Worried:

Link to post
Share on other sites
wow so many problems?? :Praying: i had brought my toy out for 3 runs so far.. 7 to 11km.. so far quite ok... only the gps.. took a while to connect.. and the worse thing is my bezel got chip off slightly...heart pain.. i remember i did not hit on anything or drop at all.. :Worried:

sometimes mine takes a while to connect too. so once i am out in the open, i quickly acquire signal and then do my warm up. if still not connected, i usually curse and swear at it and it will start to work. heh heh....

my bezel also chipped a bit. i also don't know when and where and how it happened. at first heartache... now used to it already la.

my hang twice so far, LS. i just pressed and held the 2 buttons for 20 seconds and it will reset. sometimes when you think it is hang, it is actually not. just wait for a while... leave it alone and it will continue to work.

Link to post
Share on other sites

Just to share my Garmin's 405 problem after 2 months of usage.

After the run I noticed the data recorded in the watch was with wrong date and time.

Then when I downloaded the data into the Training Centre program,

the date and time(which were wrong) also reflected to be the same as the watch history.

Emailed the US technical support, and was told to Master reset the watch to clear out any corrupt data, do note the Master reset will reset the watch to factory defaults and settings and delete all your run data.

So far 2 runs after the Master reset, all are ok. Touch wood. :Praying:

Regards

Link to post
Share on other sites
Is there anyway to turn on the backlight on the run? I cant see my speed at night!

Unlock the bezel and tap both fingers on the bezel?

yes that's right. sometimes the bezel is so sensitive, the backlight comes on when it is near my body. it also comes on when i am under the shower.

Link to post
Share on other sites

Master Reset is by holding the 2 side buttons together and hold for a few seconds?

Just to share my Garmin's 405 problem after 2 months of usage.

After the run I noticed the data recorded in the watch was with wrong date and time.

Then when I downloaded the data into the Training Centre program,

the date and time(which were wrong) also reflected to be the same as the watch history.

Emailed the US technical support, and was told to Master reset the watch to clear out any corrupt data, do note the Master reset will reset the watch to factory defaults and settings and delete all your run data.

So far 2 runs after the Master reset, all are ok. Touch wood. :Praying:

Regards

Link to post
Share on other sites

Do you folks get a very high speed in the beginning? I avg. abt 10K pace for most of my runs, but the beginning sometimes jump starts at 15+. Kinda spoils my true maximum pace of the run!

Also noticed that the elevation measurements are really off. Takes me severely below sea level even when I'm running at ECP!

However, distance and pace for the overall run are still very accurate!

Link to post
Share on other sites

When there was a lack of distance markers at the GE30km yesterday, so many runners must have wished they had a Garmin....a few runners asked me for distance and timings (maybe they were thinking I was also a Pacer yesterday...hehe).

With the Garmin, I didn't even have to look at the distance markers, and did have a slight unfair advantage lah....haha

Link to post
Share on other sites
Do you folks get a very high speed in the beginning? I avg. abt 10K pace for most of my runs, but the beginning sometimes jump starts at 15+. Kinda spoils my true maximum pace of the run!

Also noticed that the elevation measurements are really off. Takes me severely below sea level even when I'm running at ECP!

However, distance and pace for the overall run are still very accurate!

hehe depends. ECP is on reclaim land. The high speed will self adjust itself very fast, even if it hasn't settle down after detecting satellite, u press start, i find the reading to be accurate when I compare with previous runs.

Link to post
Share on other sites
Do you folks get a very high speed in the beginning? I avg. abt 10K pace for most of my runs, but the beginning sometimes jump starts at 15+. Kinda spoils my true maximum pace of the run!

Also noticed that the elevation measurements are really off. Takes me severely below sea level even when I'm running at ECP!

However, distance and pace for the overall run are still very accurate!

i kinna think that high speed at the beginning is normal.. as u are fresh and u tend to go decently fast... after 1km.. u should have settle down into a decent pace...

Link to post
Share on other sites
Do you folks get a very high speed in the beginning? I avg. abt 10K pace for most of my runs, but the beginning sometimes jump starts at 15+. Kinda spoils my true maximum pace of the run!

Also noticed that the elevation measurements are really off. Takes me severely below sea level even when I'm running at ECP!

However, distance and pace for the overall run are still very accurate!

The GPS has an error of +/- 100m deliberately added by the US government. The Garmin uses averaging to average out the error and give you a steady number. When you start, you have only a few data points therefore, the averaging does not work proper and give you strange numbers. It will settle down within 100m into your run. However, sometimes, the GPS signal can interrupted, then, it will have a spike of pace. Therefore, the max. speed is almost irrelevant in the Garmin or any GPS based watch.

For the elevation, it is a known problem due to the step increment in the Garmin in tracking elevations. If you use SportsTrack or upload to the web, it will replace it with the actually elevation on the map. Since you know you cannot fly, right? Your elevation should be exactly as the terrain.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.




×
×
  • Create New...